Update cURL version

If you have an outdated cURL version, you may receive a notification in the backend of WooCommerce. The cURL version is defined at the server level, or via your hosting provider.

What is cURL?


CURL is a command-line program for obtaining or sending files and data.

Because cURL uses libcurl, it supports a range of commonly used Internet protocols, including (currently) HTTP, HTTPS, FTP, FTPS, SCP, SFTP, TFTP, LDAP, DAP, DICT, TELNET, FILE, IMAP, POP3, SMTP, and RTSP (the last four are only supported in versions newer than 7.20.0 or 9 February 2010).

CURL supports HTTPS and performs standard SSL certificate verification when a secure protocol such as HTTPS is specified. When cURL connects to an external server via HTTPS, it will obtain the certificate from the external server and then compare the validity of the external server with its CA certificate to ensure that the external server is the server that it claims to be.

cURL is used by the bol.com API, among others, since privacy sensitive information is shared here over an HTTPS connection. That is why bol.com also requires a minimal cURL version.

How do you update the cURL version?


The cURL version can only be updated by your hosting provider. Indicate clearly in this request that it is a cURL update in connection with a protocol of an API connection.

Are you stuck?


If you cannot find a solution with your hosting provider or if you have additional questions about the cURL version, please contact us at 020 - 225 19 80 or support@woosa.nl.
How did we do with this article?